Telephone issues
Incident Report for Combell nv
Resolved
This incident has been resolved.
Posted Oct 24, 2018 - 17:20 CEST
Investigating
Due to a technical issue we are currently unreachable by landline. You can still reach us through e-mail, support ticket, slack, social media and mobile numbers.
Posted Oct 24, 2018 - 16:45 CEST