Telephone Issues
Incident Report for Combell nv
Resolved
We are reachable again!
Posted over 2 years ago. Feb 28, 2017 - 13:41 CET
Identified
Due to a technical issue with our telephony partner we are currently unreachable by landline.
You can still reach us through e-mail, support ticket, slack, social media and mobile numbers.
Posted over 2 years ago. Feb 28, 2017 - 09:32 CET