Telephone Issues
Incident Report for Combell nv
Resolved
Telephone service has been restored!
Posted almost 2 years ago. Oct 09, 2017 - 16:46 CEST
Identified
An issue with our PBX is causing our landline to be unavailable.
You can still reach us through e-mail, support ticket, slack, social media and mobile numbers.
For urgent issues you can now use your dedicated emergency / off-hours contact method defined in your SLA to reach us.
Posted almost 2 years ago. Oct 09, 2017 - 16:30 CEST